hdu 1729 Stone Game(SG函数)

Stone Game



Problem Description
This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.
 

Input
The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.
 

Output
For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.
 

Sample Input
   
   
   
   
3 2 0 3 3 6 2 2 6 3 6 3 0
 

Sample Output
   
   
   
   
Case 1: Yes Case 2: No
 

Source
“网新恩普杯”杭州电子科技大学程序设计邀请赛
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1730  1536  1404  1524  1760 
#include<cstdio>
#include<cmath>
using namespace std;
int SG(int s,int c)
{
    int t=sqrt(s);
    while(t*t+t>=s) t--;//t*t+t<s (1+t)^2+(1+t)>=s
    if(c>t) return s-c;//必胜
    else return SG(t,c);//(t,c) 与(s,c)情况等价
}
int main()
{
    int kase=1,ans,c,s,n;
    while(scanf("%d",&n)&&n)
    {
        ans=0;
        while(n--)
        {
            scanf("%d%d",&s,&c);
            ans^=SG(s,c);
        }
        printf("Case %d:\n",kase++);
        if(ans)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

你可能感兴趣的:(hdu 1729 Stone Game(SG函数))