WHOJ 1609 - Han Move【细心】

Problem 1609 - Han Move
Time Limit: 1000MS    Memory Limit: 65536KB   
Total Submit: 618   Accepted: 160   Special Judge: No
Description
Cyy and Fzz are Han Move lovers. One day, they gather together to run. They choose a circular track whose length is L m. Cyy’s speed is A m/s and Fzz’s speed is B m/s. They may choose the direction separately, i.e. they may start with the same direction or different direction. As they’re crazy, they’ll run infinitely. Gatevin, their friend, wonders the possibility of their distance is less than D m. The distance is defined as the distance on the track. The possibility is defined as the ratio between the sum of time satisfying the condition and the total time.
Input
The input file consists of multiple test cases ( around 1000000 ).
Each test case consists of 5 integers L, A, B, D, Dir in a line. The meanings of L, A, B, D are as described above. Dir means whether they are in the same direction. Dir = 1 means they are in the same direction, while Dir = 0 means they are in the opposite direction. ( 1 <= L, A, B, D <= 32768, 0 <= Dir <= 1 )
Output
For each test case, output the possibility rounded to 6 demical places in a line.
Sample Input
1200 200 400 300 0
1200 200 400 300 1
Sample Output
0.500000
0.500000
Hint

 Please pay attention to the speed of I/O.

题意:两个同学同时在一个出发点出发,有可能同向,有可能反向,可以计算相对速度,如果反向,一个人不动,另一个人的速度为两人的速度之和;如果同向,一个人不动,另一个人的速度为两人的速度之差,需要注意的是保留六位小数。

AC-code:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define abs(a) a>0?a:-a
using namespace std;
int main()
{
	int a,b,c,d,e;
	while(scanf("%d%d%d%d%d",&a,&b,&c,&d,&e)!=EOF)
	{
		int v;
		if(e==0)
		{
			v=b+c;
		}
		else
		{
			v=abs(b-c);
		}
		if(v==0)
		{
			printf("1.000000\n");
			continue;
		}
		double p=2.0*d/a;
		if(p>1)
			 printf("1.000000\n");
		else
			printf("%lf\n",2.0*d/a);
	}
	return 0;
}


你可能感兴趣的:(WHOJ 1609 - Han Move【细心】)