HDOJ 1509 Windows Message Queue(优先队列)

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4508    Accepted Submission(s): 1796


Problem Description
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
 

Input
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
 

Output
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.
 

Sample Input
   
   
   
   
GET PUT msg1 10 5 PUT msg2 10 4 GET GET GET
 

Sample Output
   
   
   
   
EMPTY QUEUE! msg2 10 msg1 10 EMPTY QUEUE!
 

Author
ZHOU, Ran
 

Source
Zhejiang University Local Contest 2006, Preliminary
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1512  1387  1710  1896  1403

结构体中除了the message name ,and two integer means the parameter ,and priority即name,mess,pri,这三个变量外,还要设置一个num用以记录进队列的先后排名,在优先队列的自定义比较中,比较的是优先级pri和先后排名num这两个量,如果WA了,建议看看你的自定义比较中是不是优先级数小的和排名数小的先输出(对的),否者改改>,<就好了,

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node{
    int mess,pri,num;//信息,优先权,先后到来
    char name[100];//名字
    friend bool operator<(node a,node b){
        if(a.pri!=b.pri) return a.pri>b.pri;
        else return a.num>b.num;
    }
};//优先级pri小的和排名num小的优先输出
int main(){
    node q;
    int i=0;//记录先后
    char str[60005];
    priority_queue <node> que;
    while(~scanf("%s",str)){
        if(str[0]=='G'){
            if(!que.empty()){
                q=que.top();
                que.pop();
                printf("%s %d\n",q.name,q.mess);
            }
            else printf("EMPTY QUEUE!\n");
        }
        else{
            scanf("%s %d %d",&q.name,&q.mess,&q.pri);
            q.num=++i;
            que.push(q);
        }
    }
    return 0;
}

 

你可能感兴趣的:(数据结构,优先队列,hdoj)