POJ 3104 Drying (二分搜索)

Drying
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10066   Accepted: 2581

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than kwater, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

k * x + (mid - x) >= a[i]  ==> x >= (a[i] - mid) / (k - 1)

根据这个式子二分就好了 - - 一开始傻了 没计算 直接搞然后就逗比了

由于除数可能为0需要特判一下 k=1的时候 自然晾干和搞干效果一样 所以 直接找到最大的就是ans


AC代码如下:

//
//  POJ 3104 Drying
//
//  Created by TaoSama on 2015-04-24
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

int n, k, a[N];

// k * x + (mid - x) >= a[i]  ==> x >= (a[i] - mid) / (k - 1)

bool check(int x) {
    int cnt = 0;
    for(int i = 1; i <= n; ++i) {
        if(a[i] > x)  cnt += (a[i] - x + k - 2) / (k - 1);
        if(cnt > x) return true;
    }
    return false;
}

int main() {
#ifdef LOCAL
    freopen("in.txt", "r", stdin);
//  freopen("out.txt","w",stdout);
#endif
    ios_base::sync_with_stdio(0);

    while(scanf("%d", &n) == 1) {
        int ans = -INF;
        for(int i = 1; i <= n; ++i) {
            scanf("%d", a + i);
            ans = max(ans, a[i]);
        }
        scanf("%d", &k);
        if(k != 1) {
            int l = 0, r = ans + 1;
            while(l + 1 < r) {
                int mid = 0LL + l + r >> 1;
                if(check(mid)) l = mid;
                else r = mid;
            }
            ans = r;
        }
        printf("%d\n", ans);
    }
    return 0;
}


你可能感兴趣的:(POJ 3104 Drying (二分搜索))