HDU2509:Be the Winner(Nim)

Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is  
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
   
   
   
   
2 2 2 1 3
 

Sample Output
   
   
   
   
No Yes
 


 

 

与HDU1907一样的Nim博弈,直接将输入输出改一点点就可以了。。。

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int main()
{
    int n,i;
    int sum1,sum2,ans;
    int a[55];
    while(~scanf("%d",&n))
    {
        sum1 = sum2 = ans = 0;
        for(i = 0; i<n; i++)
        {
            scanf("%d",&a[i]);
            ans^=a[i];
            if(a[i]>=2)
                sum2++;
            else
                sum1++;
        }
        if((ans && sum2) || (!ans && !sum2))
            printf("Yes\n");
        if((ans && sum1%2 && !sum2) || (!ans && sum2>=2))
            printf("No\n");
    }

    return 0;
}


 

你可能感兴趣的:(HDU,博弈)