http://acm.hdu.edu.cn/showproblem.php?pid=1023&&卡特兰数

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output
For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input
   
   
   
   
1 2 3 10

Sample Output
   
   
   
   
1 2 5 16796
java写的。。。。
AC代码: http://blog.csdn.net/smallacmer/article/details/7770855
import java.util.*;
import java.math.BigInteger;
public class Main {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO 自动生成方法存根
		BigInteger num[]=new BigInteger[105];
		num[1]=BigInteger.ONE;
		num[2]=BigInteger.valueOf(2);
		num[3]=BigInteger.valueOf(5);
		for(int i=4;i<105;i++)
			{
			BigInteger b=BigInteger.valueOf(4);
			b= b.multiply(BigInteger.valueOf(i)).subtract(BigInteger.valueOf(2));
            num[i]=num[i-1].multiply(b).divide(BigInteger.valueOf(i+1));
			}

		Scanner cin=new Scanner(System.in);
		int n;
		while(cin.hasNext())
		{
			n=cin.nextInt();
			System.out.println(num[n]);
		}
	}

}



你可能感兴趣的:(String,Class,input,import,each,output)