poj1276 多重背包问题(二进制解决方案)

http://poj.org/problem?id=1276

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
题目大意:给定背包的容量V,和n中物品,每种物品的数量、重量、价值分别为num,w,v。求背包可以获得的最大价值。

解题思路:一道多重背包的问题,一开始采用了以前用过的方法,结果超时了,趁机重读《背包九讲》,豁然开朗,去年怎么也看不懂的二进制做法,而今看来是这么的容易==详见《背包九讲》

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=200100;
int v,n,T,c[maxn],dp[maxn];
int main()
{
    while(~scanf("%d",&v))
    {
        scanf("%d",&T);
        n=0;
        memset(c,0,sizeof(c));
        while(T--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            int k=0;
            while(x-(1<<(k+1))+1>0)k++;
            for(int i=0;i<k;i++)
            {
                c[++n]=y*(1<<i);
            }
            c[++n]=y*(x+1-(1<<k));
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=v;j>=c[i];j--)
            {
                dp[j]=max(dp[j],dp[j-c[i]]+c[i]);
            }
        }
        printf("%d\n",dp[v]);
    }
    return 0;
}


你可能感兴趣的:(poj1276 多重背包问题(二进制解决方案))