zoj 2091 Mean of Subsequence(奇怪的贪心)

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2091

Mean of Subsequence Time Limit: 2 Seconds      Memory Limit: 65536 KB Given N numbers in a line, we can determine a continuous subsequence by giving its start position and its length.

PMH and Roy played a game the other day. Roy gives the start position first, then PMH gives the length. Roy wants the mean of the subsequence as large as possible, while PMH wants it as small as possible.

You are to calculate the best result Roy can get, assuming PMH is very clever.


Input

There are multiple testcases.

Each testcase begins with a line containing N only.

The following line contains N numbers, separated by spaces.


Output

For each testcase, you are to print the best mean of subsequece Roy can get, precise to 6 digit after decimal point.


Sample Input

10
2 10 4 6 5 10 10 2 3 2


Sample Output

5.777778

分析:说来忏愧,我并不理解为什么是这样:从a[i]开始的数字序列一定是a[i]--a[n]这一最长段的平均值最小,它的证明我没有看懂:用反证法证明:如果所选长度的最后一个数字不是n  而是kmax与n中间的某个数t,那么也就是说ave(kmax...t)<ave(kmax...n)。那么必有 ave(t+1...n)>ave(kmax...n) 说明最后t+1个数的平均数最大,与题设矛盾。
这题可以说是我很不理解的一题。。。
#include <iostream>
#include <cstdio>
using namespace std;
double a[10005],b[10005];
int main()
{
    //freopen("cin.txt","r",stdin);
    int n,i,j;
    double maxm;
    while(cin>>n){
        for(i=1;i<=n;i++) scanf("%lf",&a[i]);
        maxm=b[n]=a[n];
        for(i=n-1;i>=1;i--){
            b[i]=(a[i]+b[i+1]*(n-i))/(n-i+1);
            maxm=max(maxm,b[i]);
        }
        printf("%.6lf\n",maxm);
    }
    return 0;
}



你可能感兴趣的:(ZOJ)