Problem A: Billiard
In a billiard table with horizontal side
a
inches and vertical side
b
inches, a ball is launched from the middle of the table. After
s
> 0 seconds the ball returns to the point from which it was launched, after having made
m
bounces off the vertical sides and
n
bounces off the horizontal sides of the table. Find the launching angle
A
(measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.
Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have no pockets.
Input
Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are:
a
,
b
,
s
,
m
, and
n
, respectively. All numbers are positive integers not greater than 10000.
Input is terminated by a line containing five zeroes.
Output
For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle
A
in degrees and the second is the velocity of the ball measured in inches per second, according to the description above.
Sample Input
100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0
Sample Output
45.00 141.42
33.69 144.22
3.09 7967.81
题意:一张长a,宽b的台球桌,从中心发射一枚台球,经过若干次弹性碰撞后,又回到了中心。其中与宽边碰了m次,与长边碰了n次,并且话费了s秒的时间。求发射角(与水平边,长边的夹角),以及发射速度。
由于每次碰撞之后,相对水平和垂直的速度绝对值不变,而每一次碰撞到下次碰撞走过的距离都是一个长边,或是一个宽边。所以这道题就可以直接化为简单的计算题
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define PI acos(-1.0)
using namespace std;
int main ()
{
long long a,b,s,m,n;
double A,v;
while(cin>>a>>b>>s>>m>>n)
{
if (a==0) break;
long long L,H;
double d;
L=a*m;
H=b*n;
d=L*L+H*H;
d=sqrt(d);
v=d/s;
A=atan(H/(L*1.0))*180/PI;
printf("%.2lf %.2lf\n",A,v);
}
return 0;
}