Toy Storage
http://poj.org/problem?id=2398
Description
Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.
Input
The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.
A line consisting of a single 0 terminates the input.
Output
For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.
Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0
Sample Output
Box
2: 5
Box
1: 4
2: 1
本题和poj2318 TOYS大致一样,但有一些不同。
1:输入是无序的,需要自己排序。
2:输出是输出拥有相同玩具数的区块有几个。 (区块里的玩具数:相同玩具数的区块个数)
知道题意就很好做了。
#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm>
using namespace std;
#define MAX 5005
#define LL long long
struct line
{
LL a,b;
}seg[MAX],a,b,node;
LL counts[MAX];
map<LL,int> mat;
int n,m;
bool cmp(const line &a,const line &b)
{
return a.a<b.a;
}
int cross(int m)
{
return (seg[m].a-seg[m].b)*(node.b-b.b)-(a.b-b.b)*(node.a-seg[m].b);
}
void binarySearch()
{
//printf("node %I64d %I64d ",node.a,node.b);
int l=0,r=n,mid;
for(;l<=r;)
{
mid=(l+r)>>1;
if(cross(mid)<0)
l=mid+1;
else
r=mid-1;
}
//printf("in %d\n",l);
counts[l]++;
}
int main()
{
for(;scanf("%d",&n),n;)
{
memset(counts,0,sizeof(counts));
mat.clear();
scanf("%d",&m);
scanf("%I64d%I64d%I64d%I64d",&a.a,&a.b,&b.a,&b.b);
seg[0].a=seg[0].b=a.a;
for(int i=1;i<=n;++i) scanf("%I64d%I64d",&seg[i].a,&seg[i].b);
sort(seg,seg+n+1,cmp);
for(;m--;)
{
scanf("%I64d%I64d",&node.a,&node.b);
binarySearch();
}
//for(int i=1;i<=n+1;++i)
// printf("i=%d counts=%I64d\n",i,counts[i]);
for(int i=1;i<=n+1;++i)
{
if(counts[i]!=0)
{
if(mat.find(counts[i])!=mat.end())
mat.find(counts[i])->second++;
else
mat.insert(make_pair(counts[i],1));
}
}
puts("Box");
for(map<LL,int>::iterator it=mat.begin();it!=mat.end();++it)
printf("%I64d: %d\n",it->first,it->second);
}
return 0;
}