HDU 1051 Wooden Sticks (贪心)

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
   
   
   
   
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
   
   
   
   
2 1 3
 

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
struct Stick
{
    int length,weight;
    int flag;
};
bool cmp(Stick A,Stick B)
{
    if(A.length!=B.length)
        return A.length<B.length;
    else
        return A.weight<B.weight;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        Stick stick[5000];
        cin>>n;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&stick[i].length,&stick[i].weight);
            stick[i].flag=0;
        }
        sort(stick,stick+n,cmp);
        int len,wei,sum=0,count=0;
        while(count<n)
        {
            int i,j;
            for(i=0;i<n;i++)
                if(stick[i].flag==0)
                {
                    len=stick[i].length;
                    wei=stick[i].weight;
                    stick[i].flag=1;
                    sum++;
                    count++;
                    break;
                }
            for(j=i+1;j<n;j++)
                if(stick[j].flag==0)
                {
                    if(stick[j].length>=len&&stick[j].weight>=wei)
                    {
                        len=stick[j].length;
                        wei=stick[j].weight;
                        stick[j].flag=1;
                        count++;
                    }
                }
        }
        cout<<sum<<endl;
    }
    return 0;
}

你可能感兴趣的:(HDU 1051 Wooden Sticks (贪心))