hdu 1159 Common Subsequence(DP最长公共子序列)

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14714    Accepted Submission(s): 6106


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.


 

Sample Input
   
   
   
   
abcfbc abfcab programming contest abcd mnp


 

Sample Output
   
   
   
   
4 2 0


 

Source
Southeastern Europe 2003


 

Recommend
Ignatius

 

思路:dp[x][y],串a前x个和串b前y个的最长公共子序列。

 

#include<iostream>
#include<cstring>
using namespace std;
const int mm=5000;
char a[mm],b[mm];
int dp[mm][mm];
int lena,lenb;
int main()
{
  while(cin>>a>>b)
  {
    lena=strlen(a);lenb=strlen(b);
    for(int i=0;i<lena;i++)dp[i][0]=0;
    for(int i=0;i<lenb;i++)dp[0][i]=0;
    for(int i=1;i<=lena;i++)
      for(int j=1;j<=lenb;j++)
      if(a[i-1]==b[j-1])dp[i][j]=dp[i-1][j-1]+1;
      else dp[i][j]=dp[i-1][j]>dp[i][j-1]?dp[i-1][j]:dp[i][j-1];
      cout<<dp[lena][lenb]<<"\n";
  }
}


 

 

 

你可能感兴趣的:(hdu 1159 Common Subsequence(DP最长公共子序列))