Oulipo
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1677 Accepted Submission(s): 646
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
题意就是找模式串在母串中出现的次数,,,kmp算法。。。这里是从1开始,比较方便。。。
代码:
#include<iostream>
#include<cstdio>
#include<string.h>
#define N 10005
#define M 1000005
using namespace std;
char a[N],s[M];
int next[N];
int n,m;
void KMP_next()
{ a[0]='#';//这里是从a+1开始输入,一定要注意,给a[0]赋值
n=strlen(a);
m=strlen(s);
next[1]=0;
int j=0;
for(int i=2;i<n;i++)
{
while(j>0&&a[j+1]!=a[i])
j=next[j];
if(a[j+1]==a[i])
j++;
next[i]=j;
}
}
int KMP_match()
{ int sum=0,i=0,j=0;
for(int i=0;i<m;++i)
{ while(j>0&&a[j+1]!=s[i])
j=next[j];
if(a[j+1]==s[i])
j++;
if(j==n-1)
{ sum++;
j=next[j];
}
}
return sum;
}
int main()
{ int Case;
scanf("%d",&Case);
while(Case--)
{ //getchar();
scanf("%s%s",a+1,s);
KMP_next();
printf("%d\n",KMP_match());
} return 0;
}
这个超时的不知为什么,大牛看到时指点一下不胜感激,,,
代码:
#include<iostream>
#include<string>
#define N 10005
using namespace std;
int next[N];
int KMP_next(string &a,string &b)
{ int n=a.size();
int m=b.size();
int j=0,i=1,sum=0;
next[0]=0;
while(i<n)
{ if(a[j]==a[i])
{ next[i]=j+1;
j++;i++;
}
else{ if(j>0) j=next[j-1];
else next[i++]=0;
}
}
i=0,j=0;
while(i<m)
{ if(a[j]==b[i])
{ if(j==n-1) {sum++;j=next[j-1]; }
else {j++;i++;}
}
else { if(j>0) j=next[j-1];
else i++;
}
}
return sum;
}
int main()
{ int Case;
cin>>Case;
while(Case--)
{ string a,b;
cin>>a>>b;
cout<<KMP_next(a,b)<<endl;
} return 0;
}