POJ 2081 Recaman's Sequence

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1+ m. 
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 
Given k, your task is to calculate a k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658
 
   
 
   

#include <iostream>
#include <string.h>
using namespace std;
int p[500001],flag[10000001];
int main()
{
    memset(p,0,sizeof(p));
	memset(flag,0,sizeof(flag));
	for(int i=1;i<=500000;i++)
	{
		if(p[i-1]-i>0&&flag[p[i-1]-i]==0)
		{
		    p[i]=p[i-1]-i;
		    flag[p[i]]=1;
		}
		else
		{
		    p[i]=p[i-1]+i;
		    flag[p[i]]=1;
		} 
    }
    int k;
    while(cin>>k&&k!=-1)
     	cout<<p[k]<<endl;
	return 0;
}
 
  

你可能感兴趣的:(POJ 2081 Recaman's Sequence)