ZOJ1016 ParenCoding

Time Limit: 1 Second      Memory Limit: 32768 KB

Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:

By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.


Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.


Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.


Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9


Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

import java.util.Scanner;
import java.util.Stack;


public class Main {
	/**
	 * stack s is the parentheses sequences
	 */
	public static char[] s;
	/**
	 * array p is the P-sequences
	 */
	public static int[] p;
	/**
	 * array w is the W-sequences
	 */
	public static int[] w;
	/**
	 * n is the length of the parencodings
	 */
	public static int n;

	
	public static void main(String[] args){
		Scanner scanner = new Scanner(System.in);
		int num = scanner.nextInt();
		
		while(num >0){
			n = scanner.nextInt();
			p = new int[n];
			w = new int[n];
			s = new char[2*n];
			
			for(int i = 0;i<2*n;i++){
				s[i] = '(';
			}
			
			for(int i = 0;i<n;i++){
				p[i] = scanner.nextInt();
				s[p[i] + i] = ')';
			}
			int k;
			boolean[] flag = new boolean[2 *n];
			//index represents the index of array w
			int index = 0;
			for(int i = 0;i< 2*n;i++){
				int sum = 1;
				if(s[i]== ')'){
					for(k = i-1;k>=0;k--){
						if((s[k] == '(') && (!flag[k])){
							w[index++] = sum;
							flag[k] = true;
							break;
						}
						else if(flag[k]){
							sum++;
						}
					}
				}
			}
			/*
			 * you have to make sure the output has the right pattern
			 * first,for every line,print a space between every 2 integer
			 * of course,no space exist after the last integer
			 * also,print a wrap after every line
			 * */
			for(int i = 0;i<n;i++){
				System.out.print(w[i]);
				if(i != n-1){
					System.out.print(" ");
				}
			}
			System.out.println();
			num--;
		}
		
	}
}

你可能感兴趣的:(encoding)