http://acm.hdu.edu.cn/showproblem.php?pid=1060

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7028 Accepted Submission(s): 2703


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the leftmost digit of N^N.

Sample Input
   
   
   
   
2 3 4

Sample Output
   
   
   
   
2 2 AC代码:
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		long long n;
		cin>>n;
		double k=n*log10(double(n));
		k=k-(long long )k;//注意这里应是1long long 类型
		k=pow(10.0,k);
		while(k<1)
			k*=10;
		cout<<(int)k<<endl;
	}return 0;
}


你可能感兴趣的:(http://acm.hdu.edu.cn/showproblem.php?pid=1060)