Poj 2392(dp)

Space Elevator
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7192   Accepted: 3370

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

USACO 2005 March Gold
入门dp。贪心的先按高度限制排序,然后0-1背包就可以了。
#include<cstdio>
#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
#include<set>
#include<cstring>
using namespace std;
typedef pair<int,int> P;
const int maxn = 4000 + 5;
const int maxm = 40000 + 5;
const int INF = 100000 + 1;

int dp[2][maxm];
vector<P> v;

int main(){
    int n,h,a,c;
    while(scanf("%d",&n) != EOF){
        v.clear();
        for(int i = 0;i < n;i++){
            scanf("%d%d%d",&h,&a,&c);
            for(int j = 0;j < c;j++){
                v.push_back(P(a,h));
            }
        }
        int total = v.size();
        sort(v.begin(),v.end());
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
        if(v[0].first >= v[0].second) dp[0][v[0].second] = 1;
        for(int i = 1;i < total;i++){
            for(int j = 0;j < maxm;j++){
                if(j < v[i].second || j > v[i].first) dp[i&1][j] = dp[(i-1)&1][j];
                else dp[i&1][j] = dp[(i-1)&1][j] || dp[(i-1)&1][j-v[i].second];
            }
        }
        int ans = 0;
        for(int i = 1;i < maxm;i++){
            if(dp[(total-1)&1][i] == 1) ans = i;
        }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(Poj 2392(dp))