PAT (Advanced Level) Practise 1110 Complete Binary Tree (25)

1110. Complete Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -
Sample Output 1:
YES 8
Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -
Sample Output 2:

NO 1

问一棵树是不是完全二叉树,直接给根节点赋值1,然后左边是2,右边是3,这样判断最大的值是不是大于n即可

#include<cstdio>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 1e5 + 10;
int n, ch[maxn][2], flag[maxn], ans;
char s[maxn];

int get()
{
	scanf("%s", s);
	return s[0] == '-' ? -1 : s[1] ? s[1] - '0' + 10 * (s[0] - '0') : s[0] - '0';
}

bool dfs(int x, int y)
{
	if (x == -1) return true;
	if (y > n) return false;
	if (y == n) ans = x;
	return dfs(ch[x][0], y << 1) && dfs(ch[x][1], y << 1 | 1);
}

int main()
{
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		ch[i][0] = get();	if (ch[i][0] != -1) flag[ch[i][0]] = 1;
		ch[i][1] = get();	if (ch[i][1] != -1) flag[ch[i][1]] = 1;
	}
	for (int i = 0; i < n; i++)
	{
		if (!flag[i])
		{
			if (dfs(i, 1)) printf("YES %d\n", ans);
			else printf("NO %d\n", i);
		}
	}
	return 0;
}


你可能感兴趣的:(pat)