PAT (Advanced Level) Practise 1108 Finding Average (20)

1108. Finding Average (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
判断是不是实数,注意细节。
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
char s[maxn];
int n, cnt;
double avg;

bool check()
{
	int point = strlen(s), neg = s[0] == '-';
	for (int i = 0; s[i]; i++)
	{
		if ((s[i]< '0' || s[i] > '9') && s[i] != '.'&&s[i] != '-') return false;
		if (s[i] == '-' && i) return false;
		if (s[i] == '.') { if (s[point] || point - i > 3) return false; point = i; }
		//数据中没有".","-","-."这样的数据,且"1."和".1"是合法的。
	}
	double L = 0, R = 0;
	for (int i = neg; i < point; i++) L = L * 10 + s[i] - '0';
	for (int i = strlen(s) - 1; i>point; i--) R = (R + s[i] - '0') / 10;
	if (L + R > 1000.0) return false;
	avg += (neg ? -1 : 1) * (L + R);
	return true;
}

int main()
{
	scanf("%d", &n);
	while (n--)
	{
		scanf("%s", s);
		if (check()) cnt++; else printf("ERROR: %s is not a legal number\n", s);
	}
	if (!cnt) printf("The average of 0 numbers is Undefined\n");
	else printf("The average of %d number%s is %.2lf", cnt, cnt == 1 ? "" : "s", avg / cnt);
	return 0;
}


你可能感兴趣的:(pat)