hdoj 2824 The Euler function 【欧拉函数 简单】

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4246    Accepted Submission(s): 1767


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
   
   
   
   
3 100
 

Sample Output
   
   
   
   
3042
 

#include <cstdio>
#include <cstring>
#include <cmath>
#define LL long long
#define MAX 3000000+10
using namespace std;
LL eu[MAX];
void euler()
{
	int i, j;
	for(i = 2; i < MAX; i++)
	{
		if(!eu[i])
		{
			for(j = i; j < MAX; j += i)
			{
				if(!eu[j]) eu[j] = j;
				eu[j] = eu[j] * (i-1) / i;
			}
		}
		eu[i] += eu[i-1];
	}
}
int main()
{
	int a, b;
	euler();
	while(scanf("%d%d", &a, &b) != EOF)
	{
		printf("%lld\n", eu[b]-eu[a-1]);
	}
	return 0;
}

你可能感兴趣的:(hdoj 2824 The Euler function 【欧拉函数 简单】)