PAT (Advanced Level) Practise 1103 Integer Factorization (30)

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
可以选择直接暴力dfs+剪枝,我这里用了递推求解的办法,可以保证序列一定是递增的。
#include<cstdio>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<cmath>
#include<iostream>
#include<cstring>
#include<functional>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 1e3 + 10;
int n, K, p, c[maxn];
int f[maxn][maxn], sum[maxn][maxn], pre[maxn][maxn];
vector<int> ans;

int main()
{
	scanf("%d%d%d", &n, &K, &p);
	for (int i = 1; i; i++)
	{
		c[i] = 1;	
		for (int j = 1; j <= p; j++) c[i] *= i;
		if (c[i] > n) break;
	}
	sum[0][0] = 1;
	for (int i = 1; i <= K; i++)
	{
		for (int j = 1; j <= n; j++)
		{
			for (int k = 1; c[k] <= j; k++)
			{
				if (sum[i - 1][j - c[k]])
				{
					if (sum[i][j] < sum[i - 1][j - c[k]] + k)
					{
						sum[i][j] = sum[i - 1][j - c[k]] + k;
						pre[i][j] = k;
						f[i][j] = max(f[i - 1][j - c[k]], k);
					}
					else if (sum[i][j] == sum[i - 1][j - c[k]] + k)
					{
						if (f[i][j] <= max(f[i - 1][j - c[k]], k))
						{
							pre[i][j] = k;
							f[i][j] = max(f[i - 1][j - c[k]], k);
						}
					}
				}
			}
		}
	}
	if (!sum[K][n]) printf("Impossible\n");
	else
	{
		int x = K, y = n;
		while (x&&y)
		{
			ans.push_back(pre[x][y]);
			y -= c[pre[x][y]];	x--;
		}
		//sort(ans.begin(), ans.end(), greater<int>());
		printf("%d", n);
		for (int i = 0; i < ans.size(); i++)
		{
			printf("%s%d^%d", i ? " + " : " = ", ans[i], p);
		}
		printf("\n");
	}
	return 0;
}


你可能感兴趣的:(pat)