POJ 2231:Moo Volume【细心】

Moo Volume
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20927   Accepted: 6308

Description

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. 

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

Input

* Line 1: N 

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

Output

There are five cows at locations 1, 5, 3, 2, and 4.

Sample Input

5
1
5
3
2
4

Sample Output

40

Hint

INPUT DETAILS: 

There are five cows at locations 1, 5, 3, 2, and 4. 

OUTPUT DETAILS: 

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.
注意cow的位置的范围,so答案用long long ~~
AC-code:
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int s[10005];
int main()
{
	int n,i,j;
	long long ans;
	scanf("%d",&n);
	for(i=0;i<n;i++)
		scanf("%d",&s[i]);
	sort(s,s+n);
	ans=0;
	for(i=0;i<n;i++)
	{
		for(j=0;j<i;j++)
			ans+=s[i]-s[j];
		for(j=i+1;j<n;j++)
			ans+=s[j]-s[i];
	}
	printf("%lld\n",ans);
	return 0;
}


你可能感兴趣的:(POJ 2231:Moo Volume【细心】)