hdoj 5656 CA Loves GCD 【dp】

题目链接:hdoj 5656 CA Loves GCD

问题描述
CA喜欢是一个热爱党和人民的优秀同♂志,所以他也非常喜欢GCD(请在输入法中输入GCD得到CA喜欢GCD的原因)。
现在他有N个不同的数,每次他会从中选出若干个(至少一个数),求出所有数的GCD然后放回去。
为了使自己不会无聊,CA会把每种不同的选法都选一遍,CA想知道他得到的所有GCD的和是多少。
我们认为两种选法不同,当且仅当有一个数在其中一种选法中被选中了,而在另外一种选法中没有被选中。
输入描述
第一行 TT,表示有 TT 组数据。
接下来 TT 组数据,每组数据第一行一个整数 NN,表示CA的数的个数,接下来一行 NN 个整数 A_iA
​i
​​ 表示CA的每个数。
1 \le T \le 50,~1 \le N \le 1000,~1 \le A_i \le 10001≤T≤50, 1≤N≤1000, 1≤A
​i
​​ ≤1000
输出描述
对于每组数据输出一行一个整数表示CA所有的选法的GCD的和对 100000007100000007 取模的结果。
输入样例
2
2
2 4
3
1 2 3
输出样例
8
10

思路: dp[i][j] 表示前 i 个数得到gcd等于 j 的方案数。考虑取与不取,然后转移就好了。
dp[i][j]+=dp[i1][j],dp[i][gcd(j,a[i])]+=dp[i1][j]

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <stack>
#define PI acos(-1.0)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define fi first
#define se second
#define ll o<<1
#define rr o<<1|1
using namespace std;
typedef long long LL;
typedef pair<int, int> pii;
const int MAXN = 2*1e5 + 10;
const int pN = 1e6;// <= 10^7
const int INF = 0x3f3f3f3f;
const int MOD = 1e8 + 7;
void add(LL &x, LL y) { x += y; x %= MOD; }
int gcd(int a, int b) {
    return b == 0 ? a : gcd(b, a % b);
}
int g[1010][1010], a[1010];
void get() {
    for(int i = 1; i <= 1000; i++) {
        for(int j = 1; j <= 1000; j++) {
            g[i][j] = gcd(i, j);
        }
    }
}
LL dp[1010][1010];
int main()
{
    get();
    int t; scanf("%d", &t);
    while(t--) {
        int n; scanf("%d", &n);
        int Max = 0;
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
            Max = max(Max, a[i]);
        }
        CLR(dp, 0); dp[1][a[1]] = 1LL;
        for(int i = 2; i <= n; i++) {
            dp[i][a[i]] = 1LL;
            for(int j = 1; j <= Max; j++) {
                add(dp[i][j], dp[i-1][j]);
                add(dp[i][g[a[i]][j]], dp[i-1][j]);
            }
        }
        LL ans = 0;
        for(int j = 1; j <= Max; j++) {
            //cout << n << ' ' << j << ' ' << dp[n][j] << endl;
            add(ans, dp[n][j] * j % MOD);
        }
        printf("%I64d\n", ans);
    }
    return 0;
}

你可能感兴趣的:(hdoj 5656 CA Loves GCD 【dp】)