Radar Installation
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 43100 |
|
Accepted: 9543 |
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
Source
Beijing 2002
题意就是一个图上有n个点,要求你用尽量少的以在x轴上的点为圆心的圆覆盖这些点。对每一个点,要覆盖到它,圆心有一个确定的范围,那么对每一个点都处理出这些范围,然后问题就转化为了已知一些区间,要找最少的点,使这些区间中都至少存在一个点。这是个经典问题,对区间排序后,不停的对下一个区间取交集,如果交为空,ans++,更新当前区间范围。
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>
#include<set>
#include<map>
#include<iostream>
#include<algorithm>
#include<queue>
#include<cmath>
using namespace std;
typedef pair<int,int> P;
const int maxn = 1000 + 5;
struct Node{
double l,r;
}a[maxn];
bool cmp(Node a,Node b){
return a.l < b.l;
}
int main(){
int n,d;
int kase = 0;
while(scanf("%d%d",&n,&d) != EOF){
kase++;
if(n == 0 && d == 0) break;
int tag = 1;
for(int i = 0;i < n;i++){
int x,y;
scanf("%d%d",&x,&y);
if(y > d){
tag = 0;
continue;
}
double der = sqrt(d*d*1.0-y*y*1.0);
a[i].l = x-der;
a[i].r = x+der;
}
if(tag == 0){
printf("Case %d: -1\n",kase);
continue;
}
sort(a,a+n,cmp);
int ans = 1;
double nl = a[0].l,nr = a[0].r;
for(int i = 1;i < n;i++){
if(a[i].l < nr || fabs(a[i].l-nr) < 1e-6){
nr = min(nr,a[i].r);
}
else{
ans++;
nl = a[i].l;
nr = a[i].r;
}
}
printf("Case %d: %d\n",kase,ans);
}
return 0;
}