PAT (Advanced Level) Practise 1082 Read Number in Chinese (25)

1082. Read Number in Chinese (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:

yi Shi Wan ling ba Bai


用中文读数字,细节比较多。

#include<cstdio>
#include<stack>
#include<string>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
string up[9] = { "", "Shi", "Bai", "Qian", "Wan", "Shi", "Bai", "Qian", "Yi" };
string num[10] = { "ling", "yi", "er", "san", "si", "wu", "liu", "qi", "ba", "jiu" };
int n;
stack<string> p;

void solve(int x)
{
	for (int i = 0; x; i++, x /= 10)
	{
		if (x % 10) { if (i) p.push(up[i]); p.push(num[x % 10]); }
		else
		{
			if (i == 4) { if (x % 10000) p.push(up[i]); }
			if (p.empty() || p.top() == num[0] || p.top() == up[4]) continue;
			p.push(num[0]);
		}
	}
}

int main()
{
	scanf("%d", &n);
	solve(abs(n));
	if (n < 0) p.push("Fu");
	while (!p.empty())
	{
		cout << p.top();    p.pop();
		if (!p.empty()) printf(" ");
	}
	if (!n) printf("ling\n");
	return 0;
}


你可能感兴趣的:(pat)