ACM--方程解的个数––HDOJ 1840--Equations--水


HDOJ题目地址:传送门

Equations

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1122    Accepted Submission(s): 518


Problem Description
All the problems in this contest totally bored you. And every time you get bored you like playing with quadratic equations of the form a*X 2 + b*X + c = 0. This time you are very curious to know how many real solutions an equation of this type has.
 

Input
The first line of input contains an integer number Q, representing the number of equations to follow. Each of the next Q lines contains 3 integer numbers, separated by blanks, a, b and c, defining an equation. The numbers are from the interval [-1000,1000].
 

Output
For each of the Q equations, in the order given in the input, print one line containing the number of real solutions of that equation. Print “INF” (without quotes) if the equation has an infinite number of real solutions.
 

Sample Input
   
   
   
   
3 1 0 0 1 0 -1 0 0 0
 

Sample Output
   
   
   
   
1 2 INF


#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;
int main(){
   int n,a,b,c;
   cin>>n;
   while(n--){
      cin>>a>>b>>c;
      if(a==0){
         if(b==0){
             if(c==0){
                printf("INF\n");
             }else{
                printf("0\n");
             }
         }else{
            printf("1\n");
         }
      }else{
         int temp=b*b-4*a*c;
         if(temp<0){
            printf("0\n");
         }else if(temp>0){
            printf("2\n");
         }else{
            printf("1\n");
         }
      }
   }
}




你可能感兴趣的:(数学,ACM,hdoj,水,Equations,1840)