HDOJ 1093 A+B for Input-Output Practice (V)

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

import java.util.Scanner;


public class Main {

    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        while(n-->0){
            int m=sc.nextInt();
            int sum=0;
            for(int i=1;i<=m;i++){
                int a=sc.nextInt();
                sum+=a;
            }
            System.out.println(sum);
        }
    }

}

你可能感兴趣的:(HDOJ 1093 A+B for Input-Output Practice (V))