hdu 5349 MZL's simple problem(简单的SET容器)

题目链接

http://acm.hdu.edu.cn/showproblem.php?pid=5349

MZL's simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1654    Accepted Submission(s): 652


Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number  N  ( N106 ),representing the number of operations.
Next  N  line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than  109 .
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
   
   
   
   
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
   
   
   
   
3 4
 

这道题基本是裸的SET。。唯一要注意的就是当删除的时候要判断SET是否为空

#include <stdio.h>
#include <set>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    scanf("%d", &n);
    set <int> st;
    st.clear();
     set<int>::iterator ip;
    for(int i = 1;i <= n;i++)
    {
        int q;
        scanf("%d", &q);
        if(q==1)
        {
            int t;
            scanf("%d", &t);
            st.insert(t);
        }
        else if(q==2)
        {

            if(!st.empty())
                st.erase(st.begin());

        }
        else if(q==3)
        {
            if(st.empty())
                printf("0\n");
            else
            {

                printf("%d\n",*--st.end());
            }
        }
    }
}




你可能感兴趣的:(HDU)