杭电oj1789 Doing Homework again(贪心与队列完美碰撞)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8877    Accepted Submission(s): 5234



Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
   
   
   
   
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
   
   
   
   
0 3 5
 
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
priority_queue<int ,vector<int>,greater<int> >q;//进入队列都会从小到大排 注意:固定格式 
struct act
{
	int day;//最后期限几天后交作业 
	int score;//不交作业扣的分数 
}arr[10000];
bool cmp(act x,act y)
{
	if(x.day==y.day)
	return x.score>y.score;
	else
	return x.day<y.day;//肯定要写期限小的作业而且如果期限小的话要写扣的分大的 
}
int main()
{
	int T,n,i;
	scanf("%d",&T);
	while(T--)
	{
	while(!q.empty())//因为要有好多测试数据,所以队列要清空 注意:固定格式 
	{
		q.pop();
	}
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d",&arr[i].day);//因为题目要求 
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&arr[i].score);
		}
		sort(arr,arr+n,cmp);//按照贪心思想排序 
	int sum=0;
	for(i=0;i<n;i++)
	{
		if(q.size()<arr[i].day)//q.size()代表的是开始写作业时当天的天数如果还没达到天数先存到队列中按从小到大 
		{
			q.push(arr[i].score);
		}
		else//否则要比较扣分大小输出扣分小的当替罪羊 
		{
			int x=q.top();
			if(x<arr[i].score)
			{
				q.pop();
				q.push(arr[i].score);
				sum=sum+x;
			}
			else
				sum=sum+arr[i].score;
		}
	}
	printf("%d\n",sum);
	}
	return 0;
}

你可能感兴趣的:(杭电oj1789 Doing Homework again(贪心与队列完美碰撞))