hdu3652(数位dp)

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4184    Accepted Submission(s): 2397


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
   
   
   
   
13 100 200 1000
 

Sample Output
   
   
   
   
1 1 2 2

题意:求从1到n含有13且能整除13的数有多少个。

思路:数位dp,找状态转移方程和边界条件就好。dp[i][j][k]含义看代码。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
int dp[22][13][3];
/*
   dp[i][j][0]:前i位对13取余为j的不含13的个数。
  dp[i][j][1]:前i位对13取余为j的不含13且i+1位是1的个数。
  dp[i][j][2]:前i位对13取余为j的含13的个数。
*/
int digit[22];
int dfs(int pos,int mod,int st,bool limit)
{
    if(pos==0)  return st==2&&mod==0;
    if(!limit&&dp[pos][mod][st]!=-1)return dp[pos][mod][st];
    int ans=0;
    int end=limit?digit[pos]:9;
    for(int i=0; i<=end; i++)
        if((st==1&&i==3)||st==2)
            ans+=dfs(pos-1,(mod*10+i)%13,2,limit&&(i==end));
        else if(i==1)
            ans+=dfs(pos-1,(mod*10+i)%13,1,limit&&(i==end));
        else ans+=dfs(pos-1,(mod*10+i)%13,0,limit&&(i==end));
    if(!limit)
        dp[pos][mod][st]=ans;
    return ans;
}
int get(int x)
{
    int bj=0;
    while(x)
        digit[++bj]=x%10,x/=10;
    return dfs(bj,0,0,1);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    int n;
    while(~scanf("%d",&n))
        printf("%d\n",get(n));
    return 0;
}


你可能感兴趣的:(dp,ACM,大二)