HDU_1257

最少拦截系统

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31372    Accepted Submission(s): 12313


Problem Description
某国为了防御敌国的导弹袭击,发展出一种导弹拦截系统.但是这种导弹拦截系统有一个缺陷:虽然它的第一发炮弹能够到达任意的高度,但是以后每一发炮弹都不能超过前一发的高度.某天,雷达捕捉到敌国的导弹来袭.由于该系统还在试用阶段,所以只有一套系统,因此有可能不能拦截所有的导弹.
怎么办呢?多搞几套系统呗!你说说倒蛮容易,成本呢?成本是个大问题啊.所以俺就到这里来求救了,请帮助计算一下最少需要多少套拦截系统.
 

Input
输入若干组数据.每组数据包括:导弹总个数(正整数),导弹依此飞来的高度(雷达给出的高度数据是不大于30000的正整数,用空格分隔)
 

Output
对应每组数据输出拦截所有导弹最少要配备多少套这种导弹拦截系统.
 

Sample Input
   
   
   
   
8 389 207 155 300 299 170 158 65
 

Sample Output
   
   
   
   
2
 
<pre name="code" class="cpp">/*
	每出现一个导弹, 用当前距离最近的拦截系统去拦截。。不能拦截了就新开一个拦截系统。同时用数组记录每个拦截系统当前的高度。。==贪心 
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

#define INF 0x7fffffff
#define maxn 10000
int dp[maxn]; //表示当前第i个导弹拦截的高度 

int main() {
	int n;
	while (cin >> n) {
		int res = 0;
		while (n --) {
			int x;
			cin >> x;
			int flag = 0;
			int minH = INF;
			int tempi;
			for (int i = 0; i<res; i++) {
				if (x<=dp[i] && dp[i] - x < minH) {
					minH = dp[i] - x;
					flag = 1;
					tempi = i;
				}
			}
			if (flag == 0) {
				dp[res++] = x;
			}
			else 	dp[tempi] = x;
		}
		cout << res << endl;
	}
	return 0;
} 


 
 

你可能感兴趣的:(贪心)