杭电 2120 Ice_cream's world I

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 812    Accepted Submission(s): 476


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 


 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 


 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 


 

Sample Input
   
   
   
   
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 


 

Sample Output
   
   
   
   
3

 

在这道题中,通过判断根的相同与否来判断是否连成环。

 

#include<stdio.h>
int pre[1010];

int find(int x){
	int r,k,j;
	r=x;
	while(pre[r]!=r){
		r=pre[r];
	}
	k=x;
	while(k!=r){
		j=pre[k];
		pre[k]=r;
		k=j;
	}
	return r;
}

int main(){
	int n,m;
	while(~scanf("%d%d",&n,&m)){
			int i,x,y,c,d,count;
	for(i=0;i<n;i++) pre[i]=i;
	for(count=0,i=1;i<=m;i++){
			scanf("%d%d",&x,&y);
			c=find(x);
            d=find(y);
            if(c!=d)
            {
               pre[d]=c;
           }
           else count++;
		   }
		   printf("%d\n",count);  
	}
    return 0;
}

你可能感兴趣的:(杭电 2120 Ice_cream's world I)