HDOJ 2055 An easy problem

Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output
for each case, you should the result of y+f(x) on a line.

Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3

Sample Output
19
18
10
-17
-14
-4

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        sc.nextLine();
        while(n-->0){
            String str=sc.next();
            int m=sc.nextInt();
            char c=str.charAt(0);
            int s;
            if(c>='A'&&c<='Z'){
                s=(int)c-64;//这里有没有强转都是可以的
            }else{
                s=-1*((int)c-96);
            }
            System.out.println(s+m);
        }
    }

}

你可能感兴趣的:(HDOJ 2055 An easy problem)