poj Asteroids (二分匹配之匈牙利算法)

题目链接

http://poj.org/problem?id=3041

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18023   Accepted: 9808

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2
题目意思就是给你n*n的网格,里面有k个小行星。现在有一道光束能消灭一整行或者一整列的行星,问你把左右的小行星都消灭需要多少光束。

这道题把光束当作图的顶点,把小行星当作连接对应光束的边。这下问题就变成了最小顶点覆盖问题,因为在二分图中最小顶点覆盖等于最大匹配。

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int n,p;
int mp[550][550],vis[11000],link[11000];
int dfs(int star)
{
     int i,j,k;
     for(i=1;i<=n;i++)
     {
          if(vis[i]==0 && mp[star][i]==1)
          {
               vis[i]=1;
               if(link[i]==0 || dfs(link[i])==1){
                    link[i]=star;
                    return true;
               }
          }
     }
     return false;
}
int main()
{
    memset(mp,0,sizeof(mp));
    memset(link,0,sizeof(link));
     int t,i,j,s,z,counts,m,k;
     int x,y;
     scanf("%d%d",&n,&k);
     for(i=0;i<k;i++)
     {
         scanf("%d%d",&x,&y);
         mp[x][y]=1;
     }
     counts=0;
     for(i=1;i<=n;i++)
     {
         memset(vis,0,sizeof(vis));
         if(dfs(i))
            counts++;
     }
     printf("%d\n",counts);
}




你可能感兴趣的:(poj,网络流)