hdu2035--人见人爱A^B(快速幂函数)

B - 人见人爱A^B
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit   Status   Practice   HDU 2035

 

Description

求A^B的最后三位数表示的整数。  
说明:A^B的含义是“A的B次方”  
 

Input

输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 

Output

对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。  
 

Sample Input

      
      
      
      
2 3 12 6 6789 10000 0 0
 

Sample Output

      
      
      
      
8 984 1
 

利用二分,求解快速幂

int pow_mod(int a,int b,int n)
{
    int ans ;
    if(b == 0)
        return 1 ;
    ans = pow_mod(a,b/2,n);
    ans = ans * ans % n ;
    if( b%2 )
        ans = ans*a % n ;
    return ans ;
}

 

 

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int pow_mod(int a,int b,int n)
{
    int ans ;
    if(b == 0)
        return 1 ;
    ans = pow_mod(a,b/2,n);
    ans = ans * ans % n ;
    if( b%2 )
        ans = ans*a % n ;
    return ans ;
}
int main()
{
    int a , b ;
    while(scanf("%d %d", &a, &b)!=EOF)
    {
        if(a == 0 && b == 0)
            break;
        printf("%d\n", pow_mod(a,b,1000) );
    }
    return 0;
}


 

 

你可能感兴趣的:(hdu2035--人见人爱A^B(快速幂函数))