HDOJ 5631 Rikka with Graph(并查集)

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 172    Accepted Submission(s): 74


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
   
   
   
   
1 3 1 2 2 3 3 1 1 3
 

Sample Output
   
   
   
   
9
 
题意:给一个n个点n+1条边的图,选择删去一些边(至少一条),有多少方案使得删边后任是连通图?

题解:有个n点的图,至少有n-1条边才能保证连通,所以我们枚举删去一条边和删去两条边的这两种情况的所有可能,对于每种可能我们用并查集判断是否连通。

代码如下:

#include<cstdio>
#include<cstring>
int u[110],v[110],n;
bool use[110];
int tree[110];

int find(int x)
{
	if(tree[x]==x)
		return x;
	else
		return tree[x]=find(tree[x]);
} 

void merge(int a,int b)
{
	int fa=find(a);
	int fb=find(b);
	if(fa!=fb)
		tree[fa]=fb;
}

bool judge()//判断是否连通 
{
	int i;
	for(i=1;i<=n;++i)
		tree[i]=i;
	for(i=0;i<=n;++i)
	{
		if(use[i])
			merge(u[i],v[i]);
	}
	int cnt=0;
	bool sign=true;
	for(i=1;i<=n;++i)
	{
		if(tree[i]==i)
			cnt++;
		if(cnt>1)
		{
			sign=false;
			break;
		}
	}
	return sign;
}

int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<=n;++i)
		{
			scanf("%d%d",&u[i],&v[i]);
			use[i]=true;
		}
		int ans=0;
		for(i=0;i<=n;++i)
		{
			use[i]=false;
			if(judge())//删去一条边 
				ans++;
			for(j=i+1;j<=n;++j)
			{
				use[j]=false;
				if(judge())//删去两条边 
					ans++;
				use[j]=true;
			}
			use[i]=true;
		}
		printf("%d\n",ans);
	}
	return 0;
}


你可能感兴趣的:(HDOJ 5631 Rikka with Graph(并查集))