1408192118-hd-As Easy As A+B.cpp

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2489 Accepted Submission(s): 1198

 
Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 
Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
 
Output
For each case, print the sorting result, and one line one case.
 
Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9
 
Sample Output
1 2 3
1 2 3 4 5 6 7 8 9
 

题目大意

      给你一串数据让你从小到排序并输出来,跟a+b一样容易。

代码

<span style="font-size:18px;">#include<stdio.h>
#include<algorithm>
using namespace std;
int s[1100];
int main()
{
	int t,n;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		    scanf("%d",&s[i]);
		sort(s,s+n);
		for(i=0;i<n;i++)
		{
			printf("%d",s[i]);
			if(i!=n-1)
			    printf(" ");
		}
		printf("\n");
	}
	return 0;
}</span>


 

你可能感兴趣的:(1408192118-hd-As Easy As A+B.cpp)