A+B for Input-Output Practice (VIII)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 100457 Accepted Submission(s): 30946


Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
   
   
   
   
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3

Sample Output
   
   
   
   
10 15 6

Author
lcy

源代码:
#include <stdio.h>
#include <stdlib.h>

int main()
{
  int i,j,n,m,sum,num;
  scanf("%d",&n);
  for(i = 0;i < n;i++)
  {
    sum = 0;
    scanf("%d",&m);
    for(j = 0;j < m;j ++)
    {
      scanf("%d",&num);
      sum+=num;        
    } 
    if(i < n-1)
      printf("%d\n\n",sum);
    else
    printf("%d\n",sum);
  }   
  system("pause");
  return 0;    
}

你可能感兴趣的:(数据,printf,测试)