数据结构实验之链表三:链表的逆置

题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

输入

输入多个整数,以-1作为结束标志。

输出

输出逆置后的单链表数据。

示例输入

12 56 4 6 55 15 33 62 -1

示例输出

62 33 15 55 6 4 56 12

提示

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
}*head,*p,*q;
int main()
{
    int x;
    head = new node;
    head->next = NULL;
    node *p = head;
    while(scanf("%d",&x)!=EOF)
    {
        if(x==-1) break;
        node *q=new node;
        q->data=x;
        q->next=NULL;
        p->next=q;
        p=q;
    }
    p=head->next;
    head->next=NULL;
    q=p->next;
    while(p!=NULL)
    {
        p->next=head->next;
        head->next=p;
        p=q;
        if(q!=NULL)
            q=q->next;
    }
    for(node *p=head->next;p!=NULL;p=p->next)
    {
        printf("%d ",p->data);
    }
    return 0;
}

你可能感兴趣的:(编程,C语言)