Zipper
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7188 Accepted Submission(s): 2571
Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.
For example, consider forming "tcraete" from "cat" and "tree":
String A: cat
String B: tree
String C: tcraete
As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":
String A: cat
String B: tree
String C: catrtee
Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.
For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
Output
For each data set, print:
Data set n: yes
if the third string can be formed from the first two, or
Data set n: no
if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
Sample Input
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no
题意:输入三个字符串,aa,bb,cc。 cc是由aa和bb组成的。但是aa和bb在cc中的原顺序不变。问cc是否可以由aa和bb构成。
做法:dfs,要记录状态。先拿aa的当前字母去试,能匹配cc的当前字母,就继续搜下去。不能的话搜索bb当前字母和cc的当前字母是否匹配。
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>
char aa[1010],bb[1010],cc[1010];
int dp[1010][1010];
int la,lb,lc;
int dfs(int ta,int tb,int tc)
{
if(dp[ta][tb]!=-1)
return dp[ta][tb];
if(tc==lc)
return 1;
if((ta!=la&&aa[ta]==cc[tc])&&dfs(ta+1,tb,tc+1))
return 1;
if((tb!=lb&&bb[tb]==cc[tc])&&dfs(ta,tb+1,tc+1))
return 1;
return dp[ta][tb]=0;
}
int main()
{
int n;
scanf("%d",&n);
for(int cas=1;cas<=n;cas++)
{
scanf("%s%s%s",aa,bb,cc);
la=strlen(aa);
lb=strlen(bb);
lc=strlen(cc);
memset(dp,-1,sizeof dp);
if(la+lb==lc&&dfs(0,0,0))
printf("Data set %d: yes\n",cas);
else
printf("Data set %d: no\n",cas);
}
cin>>n;
return 0;
}