HDU-1847-Good Luck in CET-4 Everybody!【sg定理】【博弈】

HDU-1847-Good Luck in CET-4 Everybody!

Problem Description
大学英语四级考试就要来临了,你是不是在紧张的复习?也许紧张得连短学期的ACM都没工夫练习了,反正我知道的Kiki和Cici都是如此。当然,作为在考场浸润了十几载的当代大学生,Kiki和Cici更懂得考前的放松,所谓“张弛有道”就是这个意思。这不,Kiki和Cici在每天晚上休息之前都要玩一会儿扑克牌以放松神经。
“升级”?“双扣”?“红五”?还是“斗地主”?
当然都不是!那多俗啊~
作为计算机学院的学生,Kiki和Cici打牌的时候可没忘记专业,她们打牌的规则是这样的:
1、 总共n张牌;
2、 双方轮流抓牌;
3、 每人每次抓牌的个数只能是2的幂次(即:1,2,4,8,16…)
4、 抓完牌,胜负结果也出来了:最后抓完牌的人为胜者;
假设Kiki和Cici都是足够聪明(其实不用假设,哪有不聪明的学生~),并且每次都是Kiki先抓牌,请问谁能赢呢?
当然,打牌无论谁赢都问题不大,重要的是马上到来的CET-4能有好的状态。

Good luck in CET-4 everybody!

Input
输入数据包含多个测试用例,每个测试用例占一行,包含一个整数n(1<=n<=1000)。

Output
如果Kiki能赢的话,请输出“Kiki”,否则请输出“Cici”,每个实例的输出占一行。

Sample Input
1
3

Sample Output
Kiki
Cici

题目链接:HDU-1847

题目思路:

方法1. 可以找规律,发现只要你留给对手的牌数为3的倍数时,那么你就必赢
方法2. 求sg值,套用模板,详见代码

//
// practice.cpp
// summer-1
//
// Created by pro on 16/7/9.
// Copyright (c) 2016年 loy. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <functional>
#include <numeric>
#include <stack>
#include <map>
#include <queue>
#include<iomanip>
using namespace std;
const int maxn = 1010;
int sg[maxn],s[maxn];
int n;
void init(int t)
{
    s[0] = 1;
    for (int i = 1; i < t; i++)
    {
        s[i] = s[i - 1] * 2;   //这里自己写摸牌规律,根据题意,每次是2的倍数
    }
}
void sg_solve(int t,int N)
{
    int i,j;
    bool hash[N];
    memset(sg,0,sizeof(sg));
    for (i = 1; i <= N; i++)
    {
        memset(hash,0,sizeof(hash));
        for (j = 0; j < t; j++)
        {
            if (i - s[j] >= 0)
            {
                hash[sg[i-s[j]]] = 1;
            }
        }
        for (j = 0; j < N; j++)
        {
            if (!hash[j]) { sg[i] = j; break; }
        }
    }
}
int main()
{
    init(11);
    sg_solve(11,1000);

    while(cin >> n)
    {
        if (sg[n]) cout << "Kiki\n";
        else cout << "Cici\n";
    }
    return 0;
}

你可能感兴趣的:(HDU,博弈,sg,1847)