PAT 1023. Have Fun with Numbers (20)

http://pat.zju.edu.cn/contests/pat-a-practise/1023

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
我是水货,我每天都A一道水题,开森~(┬_┬)
#include <cstdio>
#include <string>
#include <iostream>
using namespace std;
int cnt1[10] = { 0 }, cnt2[10] = {0};

int main(){
	string s;
	cin >> s;
	string s2 = s;
	for (int i = 0; i < s.size(); i++){
		cnt1[s[i] - '0']++;
	}
	int carry = 0;
	for (int i = s.size() - 1; i >= 0; i--){
		s2[i] = ((s[i] - '0') * 2 + carry )% 10 + '0';
		carry = ((s[i] - '0') * 2 + carry) / 10;
	}
	if (carry){
		char c = carry + '0';
		s2 = c + s2;
		cout << "No\n" << s2 << endl;
		return 0;
	}
	for (int i = 0; i < s2.size(); i++){
		cnt2[s2[i] - '0']++;
	}
	bool flag = true;
	for (int i = 0; i < 10; i++){
		if (cnt1[i] != cnt2[i]){
			flag = false;
			break;
		}
	}
	if (flag) cout << "Yes" << "\n" << s2 << endl;
	else cout << "No\n" << s2;
	return 0;
}


你可能感兴趣的:(PAT 1023. Have Fun with Numbers (20))