BestCoder-四条边是否能组成四边形

CA Loves Stick

Accepts: 381
Submissions: 3204
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 262144/262144 K (Java/Others)
Problem Description

CA loves to play with sticks.One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.(What is quadrilateral? Click here:https://en.wikipedia.org/wiki/Quadrilateral)

Input

First line contains TTT denoting the number of testcases.TTT testcases follow. Each testcase contains four integers a,b,c,da,b,c,da,b,c,d in a line, denoting the length of sticks.1≤T≤1000, 0≤a,b,c,d≤263−11 \le T \le 1000,~0 \le a,b,c,d \le 2^{63}-11T1000, 0a,b,c,d2631

Output

For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).

Sample Input
2
1 1 1 1
1 1 9 2
Sample Output
Yes
No

四条边能组成四边形:最长边小于其余三条边的和

#include<iostream>
#include<cstring>
#include<cstdio>
#include<malloc.h>
#include<algorithm>
using namespace std;

int main()
{
    int ca,i;
    scanf("%d",&ca);
    unsigned long long a[4];
    while(ca--)
    {
        for(i=0; i<4; ++i)
            cin>>a[i];
        sort(a,a+4);
        if((a[0]>a[3]-a[2]-a[1])&&a[0]!=0&&a[1]!=0&&a[2]!=0&&a[3]!=0)//最大边大于剩下三边之和,注意longlong相加会超长度!!还有注意边长为0的情况!!
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


你可能感兴趣的:(C语言,bc)