zzuli OJ 1022: 三整数排序

Description

 从键盘输入三个整数x,yz,按从大到小的顺序输出它们的值。

Input

输入三个整数x,yz


Output

按从大到小的顺序输出它们的值。


Sample Input

20 16 18

Sample Output

20 18 16

HINT

 ...

Source

...


#include<stdio.h>

int main(void)
{
	int a, b, c, temp;

	scanf("%d%d%d", &a, &b, &c);

	if(a < b ) //若a>b,则交换a和b中内容
    {
        temp = a; //将a中内容咱存入temp
        a = b; //将b中内容存入a中
        b = temp; //将temp中内容存入b中
    }

    if(a < c ) //若a>c,则交换a和c中内容
    {
        temp = a; //将a中内容咱存入temp
        a = c; //将c中内容存入a中
        c = temp; //将temp中内容存入c中
    }

    if(b < c ) //若b>c,则交换b和c中内容
    {
        temp = b; //将b中内容咱存入temp
        b = c; //将c中内容存入b中
        c = temp; //将temp中内容存入c中
    }

    printf("%d %d %d\n", a, b, c);
	return 0;
}


你可能感兴趣的:(c,算法,C语言,ACM)