YTU-OJ-Problem I: 熟悉题型——类设计( 矩形类定义【C++】)

Problem I: 熟悉题型——类设计( 矩形类定义【C++】)

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 145   Solved: 94
[ Submit][ Status][ Web Board]

Description

定义一个矩形类,数据成员包括左下角和右上角坐标,定义的成员函数包括必要的构造函数、输入坐标的函数,以及计算并输出矩形面积的函数。要求使用提示中给出的测试函数并不得改动。

Input

四个数,分别表示矩形左下角和右上角顶点的坐标,如输入3.7 0.4 6.5 4.9,代表左下角坐标为(3.7, 0.4),右上角坐标为(6.5, 4.9)。

YTU-OJ-Problem I: 熟悉题型——类设计( 矩形类定义【C++】)_第1张图片

请根据给出的主函数,完成矩形类设计。

Output

输出一共有3行(请参考提示(hint)中的main函数):
第一行:由输入的坐标确定的矩形对象p1的面积
第二行:由对象复制得到的矩形对象p2的面积
第三行:直接初始化得到的矩形对象p3的面积

Sample Input

3.7 0.4 6.5 4.9

Sample Output

12.6
12.6
10

HINT

int main()



{



Rectangle p1;



p1.input();



p1.output();



Rectangle p2(p1);



p2.output();



Rectangle p3(1,1,6,3);



p3.output();



return 0;



}


#include <iostream>
#include <cmath>
using namespace std;
class Rectangle
{
private:
    double x1,y1,x2,y2;
public:
    Rectangle()
    {
        x1=x2=y1=y2=0;
    }
    Rectangle(double x,double y,double xx,double yy):
        x1(x),y1(y),x2(xx),y2(yy) {}
    void input()
    {
        cin>>x1>>y1>>x2>>y2;
    }
    void output()
    {
        cout<<fabs(x1-x2)*fabs(y1-y2)<<endl;
    }
};

int main()
{
    Rectangle p1;
    p1.input();
    p1.output();
    Rectangle p2(p1);
    p2.output();
    Rectangle p3(1,1,6,3);
    p3.output();
    return 0;
}


你可能感兴趣的:(C++)