hdu-1049 Climbing Worm

                             Climbing Worm

Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input

10 2 1

20 3 1

0 0 0

 
Sample output
17
19
题意:给出高度n,每分钟爬的高度u,休息时每分钟下滑的高度。先爬一分钟再休息一分钟,如此类推,直到爬到了高度n。求花了多少分钟。当n=0时结束。又是小学生数学题呀,有木有!!!
#include<iostream>
using namespace std;
int main()
{
	int n,u,d;  //n表示要爬的高度,u表示每分钟爬的高度,d表示每爬完一分钟后休息的一分钟内下滑的高度
	while(cin>>n>>u>>d)
	{
		if(n==0)   //n=0时结束
			break;
		int min;   //记录所花的时间
		int dis=0;  //记录已爬的高度
		for(min=1;;min++)
		{
			//先爬一分钟,再休息一分钟
			if(min%2==0)  
			{
				dis-=d;
			}
			else
			{
				dis+=u;
				if(dis>=n) //如果达到了高度n,结束
					break;
			}
		}
		cout<<min<<endl;
	}
	return 0;
}

 

你可能感兴趣的:(REST,Integer,input,each,output)