Milking Time(DP)

Milking Time
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4283   Accepted: 1775

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

 

       题意:

       给出 N,M,R,代表总共时长为 N ,有 M 个容器,每个容器需要间隔 R 的时间才能用下一个。需要给牛喂奶,后给出 M 个容器的使用时间 S(起时),E(终时)与 产量 W。要如何安排时间使最后产量达到最大。

 

       思路:

       DP。先将时间以结束时间由小到大排序一遍。dp [ i ] 代表选择第 i 个容器时可以获得的最大产量。所以 dp [ i ] = max (dp [ j ] + cow [ i ].val,dp [ i ] )( j <= i && cow[ j ].End + r <= cow [ i ].Sta )。最后还要算出所有容器 dp 出来的最大值才是答案。初始化时,每个 dp 对应为自身的 val 值,所以 dp [ i ] 代表一定会选择自己本身的这个容器。

       

       为什么要由小到大排序?

       因为要最大利用时间,若不排序的话,那么根据判断条件 cow [ j ].End + r <= cow [ i ].Sta,要求的是上一个的结束时间 + 间隙 小于 要该容器的开始时间才能进行更新,不排序的话,那么有些容器就可能会跟新不到了。故要由小到大排序。

 

       AC:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int MAX = 1005;

typedef struct { int Sta, End, val; } node;

node cow[MAX];
int dp[MAX];

int cmp(node a, node b) { return a.End < b.End; }

int main () {
        int n, m ,r;
        scanf("%d%d%d", &n, &m, &r);

        for (int i = 0; i < m; ++i)
                scanf("%d%d%d", &cow[i].Sta, &cow[i].End, &cow[i].val);

        sort(cow, cow + m, cmp);
        for (int i = 0; i < m; ++i) dp[i] = cow[i].val;

        int max_num = 0;
        for (int i = 0; i < m; ++i) {
                for (int j = i + 1; j < m; ++j) {
                        if (cow[i].End + r <= cow[j].Sta)
                                dp[j] = max(dp[j], dp[i] + cow[j].val);
                }
                max_num = max(max_num, dp[i]);
        }

        printf("%d\n", max_num);

        return 0;
}

 

 

你可能感兴趣的:(time)