Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13098 Accepted Submission(s): 6187
Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.
Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
Sample Input
1 5
10 20
Sample Output
6
30
#include<stdio.h> int main(){ int a, b; while(~scanf("%d%d", &a, &b)) printf("%d\n", a + b); return 0; }
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7593 Accepted Submission(s): 5398
Description
Your task is to Calculate a + b.
Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
Sample Input
2
1 5
10 20
Sample Output
6
30
#include<stdio.h> int main(){ int a, b, t; scanf("%d", &t); while(t--){ scanf("%d%d",&a, &b); printf("%d\n", a + b); } return 0; }
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8870 Accepted Submission(s): 5142
Description
Your task is to Calculate a + b.
Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.
Sample Input
1 5
10 20
0 0
Sample Output
6
30
#include<stdio.h> int main(){ int a, b, t; while(~scanf("%d%d", &a, &b) && a || b) printf("%d\n", a + b); return 0; }
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7942 Accepted Submission(s): 4814
Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15
#include<stdio.h> int main(){ int t, num, sum; while(~scanf("%d", &t) && t){ sum = 0; while(t--){ scanf("%d", &num); sum += num; } printf("%d\n", sum); } return 0; }
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6184 Accepted Submission(s): 4653
Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
Sample Output
10
15
#include<stdio.h> int main(){ int n, t, num, sum; scanf("%d", &t); while(t--){ sum = 0; scanf("%d", &n); while(n--){ scanf("%d", &num); sum += num; } printf("%d\n", sum); } return 0; }
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6284 Accepted Submission(s): 4538
Description
Your task is to calculate the sum of some integers.
Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.
Output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
Sample Output
10
15
#include<stdio.h> int main(){ int n, num, sum; while(~scanf("%d", &n)){ sum = 0; while(n--){ scanf("%d", &num); sum += num; } printf("%d\n", sum); } return 0; }
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6634 Accepted Submission(s): 4496
Description
Your task is to Calculate a + b.
Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line.
Sample Input
1 5
10 20
Sample Output
6
30
#include<stdio.h> int main(){ int a, b; while(~scanf("%d%d", &a, &b)) printf("%d\n\n", a + b); return 0; }
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13966 Accepted Submission(s): 4508
Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10
15
6
#include<stdio.h> int main(){ int t, n, num, sum; scanf("%d", &t); while(t--){ sum = 0; scanf("%d", &n); while(n--){ scanf("%d", &num); sum += num; } printf("%d\n", sum); if(t > 0){ printf("\n"); } } return 0; }
唯一需要说明的是最后一次输出不应有空行。
=======================签 名 档=======================
原文地址(我的博客):http://www.clanfei.com/2012/07/1543.html
欢迎访问交流,至于我为什么要多弄一个博客,因为我热爱前端,热爱网页,我更希望有一个更加自由、真正属于我自己的小站,或许并不是那么有名气,但至少能够让我为了它而加倍努力。。
=======================签 名 档=======================