POJ 2231 Moo Volume

Moo Volume
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18163   Accepted: 5347

Description

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. 

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

Input

* Line 1: N 

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

Output

There are five cows at locations 1, 5, 3, 2, and 4.

Sample Input

5
1
5
3
2
4

Sample Output

40
题目大意:  给定一串数字,求任意两个数字之差的和。
#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
using namespace std;

int main()
{
    int n;
    scanf("%d", &n);
    long long temp[10005] = {0};
    long long a[10005] = {0};
    long long sum = 0;
    for (int i = 1; i <= n; i++)
    {
        scanf("%lld", &a[i]);
    }
    sort(a + 1, a + n + 1);
    for (int i = 2; i <= n; i++)
    {
        temp[i] = temp[i - 1] + (i - 1) * (a[i] - a[i - 1]);
        sum += temp[i];
    }
    printf("%lld\n", sum * 2);
    return 0;
}

 

你可能感兴趣的:(poj)