模拟 --- 算法优化

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27943    Accepted Submission(s): 7333


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
 

 

Sample Input
2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0
 

 

Sample Output
0.71
0.00
0.75
 
 
 
【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1007
【题目大意】
首先输入一个整数n,代表有n个点,然后输入n行,每行包括两个实数(x,y),计算这些点之间的最小距离。
题目很简单,但是有一个小细节还是很重要的,所以就总计一下。
【细节&&重点】
这题如果纯模拟的话肯定超时,所以说要用到一个小技巧,下面程序中会有讲解。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
struct Node
{
    double x,y;
};
Node a[100010];

double ans=0;

double dis(Node a,Node b)
{
    return sqrt(pow(a.x-b.x,2)+pow(a.y-b.y,2));
}

int cmp(Node a,Node b)
{
    if(fabs(a.x-b.x)<1e-8)
        return a.y<b.y;
    return a.x<b.x;
}

int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int i,j,k,l;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&a[i].x,&a[i].y);
        }
        double m=1e+10;
        sort(a,a+n,cmp);//排序

       if(n==2)//**
         m=dis(a[0],a[1]);
       for(int i=0;i<n-2;i++)//重点
       {
         m=min(m,min(dis(a[i],a[i+1]),min(dis(a[i],a[i+2]),dis(a[i+1],a[i+2]))));
       }
        printf("%.2lf\n",m/2.0);
    }
    return 0;
}

 

 

你可能感兴趣的:(算法)